What happened? Only schema was migrated, no data. :(

Mar 20, 2015 at 2:19 AM
I ran the migration wizard for a database from SQL Server 2014 to SQL Azure - I chose "Analyze/Migrate Database". It worked beautifully, said it completed successfully. I see the database up in Azure. I connect to it using SSMS - the schema is perfect. But there is no data. I don't understand why. Sorry if this is real obvious - I'm brand new to SQL Azure. Please help!
Mar 20, 2015 at 4:01 AM
After you selected your objects (all by default), did you select the "Advanced" button and tell it to migrate Schema and Data? By default, just the Schema is done and no data. If you didn't do data, no problem. Just run SQLAzureMW again and then hit the "Advanced" button and tell it Data Only. SQLAzureMW will BCP out your data and then you can load it.

If you did hit the Advanced button and specify Schema and Data you should see the BCP output in your analysis window. If not, then something might be missing from the SQL Install.

Hope this helps,
Mar 20, 2015 at 11:26 PM
Oh gosh. I didn't expect that the schema AND data wouldn't be the default. That seems like a 'basic' option, not advanced. My mistake.

Well - I found it easily - and it worked in the migration wizard. It even told me how many rows were copied in each table. spot checking it, the counts up to the log.

HOWEVER, :( when I go to SSMS and connect to my SQL Azure - it shows 0 records in each of the tables.

What's also curious is the right click menu on the tables is different in the SSMS from the on-prem version versus the Azure version.
  • The on-prem right click menu has "New Table.... Design Select Top 1000 Rows Edit top 200 rows, etc" (typical)
  • the Azure right click menu only shows: "New Table... Script table as View Dependencies Memory Optimization Advisor Reports Rename Delete Refresh"
This leads me to think that the actual migration DID work (since it told me the accurate rows copied); but because the right click menus on the table in SSMS are showing different, something isn't SET right somewhere - but I don't know where.

Sure hoping you can help - I'm so anxious to start playing with SQL Azure.

Thanks so much!
Mar 21, 2015 at 2:31 AM
No, I had to turn off migrating data so many times, that I just left it off by default. I have been working with some large databases and I find that it is easier to just migrate the schema first because it could take 12 to 48 hours to migrate just the data. So, I have found it easer to migrate the schema first and make sure that things work and then migrate just the data. Note that if you have several databases you want to migrate, you can modify SQLAzureMW.exe.config file and set the default to Schema and Data. I will see what I can do here to make this more user friendly.

That said, when you migrate the data, you will notice BCP output with the row count. Then once you have your data exported, you need to upload your data to the target server. So, my first question to you would be did you complete the second step and upload the data to your target server? By default, I have 8 parallel threads uploading data, so you would have seen SQLAzureMW pop up 8 tab controls and then output the BCP upload data to a status tab. If the upload failed for any reason you would have see the tab turn red and it would have asked you to retry or abort the BCP upload. Did you see what I described above? I would recommend that you try again and then save off the status after you complete step two and maybe share it with me if possible. If you want, feel free to contact me offline.

Mar 22, 2015 at 7:47 PM

You are correct – I did not ‘upload my data to the target server’. I guess I’m not sure where this part is done? (I watched the video you did on Channel 9 too). I ran the wizard, went through the prompts, everything completed, everything green, no red errors. I’m so sorry – what am I missing? Do I manually have to upload the data to SQL Azure? I didn’t see this in the instructions – don’t understand if it’s part of the wizard – how does it get executed that it didn’t happen already.

I know I must be missing something obvious – but maybe others might miss it too? (probably not – just me).


Mar 23, 2015 at 3:33 AM
Hi Sandy,

I will contact you offline and we can walk through the process.