Ran SQLAzureMW but Azure database not updated

Feb 29, 2012 at 8:52 PM

I downloaded Version 3.8.4 today.

I followed the wizard to upload 8 tables from a local database to Azure.

The script was created and I saved a copy.  The .dat files were created and have the rows from the local database.  The script was created with the create and drop option in the advanced properties.

The script was processed from about 450 entries.  All results were green with sucess.  There were no red items.  The processing for the BCP part shows all records were processed.  The number of row uploaded to BCP was about 40,000.  The processing took 1 minute and 23 seconds.

When I run a row count on the Azure database for the 8 tables, there are no rows.  Nothing was updated to Azure.  What is the problem???

Yesterday, I used SSIS to upload 8 tables from the same local database.  SSIS took about 20 minutes to upload 40,000 records.  The rows are in Azure.

Bob Neal

Feb 29, 2012 at 9:36 PM

Hi Bob,

Yes, this is a problem.  I will contact you offline and we can figure out what is going on.


Mar 4, 2012 at 1:25 AM

Hi Bob,

Thanks for working with me.  I posted the fix in v3.8.5.  For others, the issue was due to a space in the user name.  I needed to put quotes around the name in the BCP command.


Jun 15, 2012 at 8:32 AM


Am using SQLAzureMW v.3.8.9 and I am having this same issue.  I will say I have an @ symbol in my password and an underline in my user name.  Any help would be appreciated.


Jun 15, 2012 at 8:49 AM

Fixed it :D And sorry to have bothered.

The problem here wasn't with your tool, but with the path set to the bcp.exe set in my environment variables.  I seem to have a couple of version of SQL Server installed, and the older version doesn't support the -d switch on the command line.

I renamed the old version of bcp.exe to __bcp.exe, re-ran your tool and bingo!  It worked.

So maybe in your next version have warning/error messages to say that it didn't execute properly.  Otherwise amazing tool!  Better than the import/export wizard built into SQL Server!