1
Vote

Built-in function 'has_dbaccess' is not supported in this version of SQL Server.

description

Hi All,
 
I am getting this error when trying to connect to my SQL Azure Database. I need to migrate from SQLAzure US to SQL Azure EU. I am using SQL Express 2008 SP1, does the software need SQL 2008 R2 to complete a migration from SQLAzure to SQLAzure?
 
Any help or advice will be greatly appricated
 
Kind Regards
 
John Galvin

comments

ghuey wrote Oct 14, 2010 at 3:04 PM

Hi John,

SQLAzureMW v3x requires SQL Server 2008 R2 release bits in order to run. If you can't install SQL Server 2008 R2 bits, then you can try SQLAzureMW v2.1 which is also available on the download page. If you want, you can contact me directly through Codeplex.

Regards,
George

jnl001 wrote Jan 30, 2013 at 7:30 PM

Version 2.1 does not appear on the download page. Is it still available George?

John.

ghuey wrote Jan 31, 2013 at 1:46 AM

Sorry to say, v2.1 died when SQL Azure was updated (July of 2011 I think). After that update, all applications that used SMO were required to build on SQL Server 2008 R2 SP1 bits or later. Is there something special you are looking for?

Regards,
George