SQLAzureMWBatchBackup fails but SQL Azure Migration Wizard runs

Jun 27 at 4:39 PM
I have been using SQL Azure Migration Wizard successfully to migrate databases.
I tried to use SQLAzureMQBatchBackup with the same credentials and same database and it fails with error:

An exception occurred while executing a Transact-SQL statement or batch.

I see a results.txt file
SQLAzureMWBatchBackup, Version 3.15.6.1
Process started at 6/27/2016 4:23:11 PM -- UTC -> 6/27/2016 4:23:11 PM ...

I see an empty SQL file in the directory as well.
I have tried using appsettings and command line arguments and I get the same error.


What is different between SQLAzureMigration Wizard and batch backup?

Let me know if you have any suggestions.
Coordinator
Jun 29 at 2:01 AM
You are not the first person to report this issue and I can't reproduce it on my machine (three of them). If you have Visual Studio and know C#, then you can pull the code and build on your machine and see if you can find the issue. Anyway, I will keep on looking for it.

I take it that you are running SQL Server 2008 R2 SP1 (or greater) on your machine. If you are running SQL Server 2012 (run v4.15.6) or SQL Server 2014 (run v5.15.6).

As far as the difference, SQLAzureMW is a GUI based app while batch backup is a command line app.

What version of SQL are you running?

Thanks,
George
Jun 29 at 8:16 PM
I was running the wrong version of SQLAzureMWBatch. I began using the latest version and my problems went away.

Thanks