Access only allowed using a security-enabled connection string

Mar 4 at 5:00 PM
Hi,

I am trying to connect to my Target Azure SQL server and am getting the following error when I click 'Connect'


Cannot open database 'master' on server XXXXXX requested by the login. Access to the database is only allowed using a security-enabled connection string. Changed database context to 'master'

I'd appreciate any advice!
Coordinator
Mar 4 at 5:42 PM
Hi,

Do you have auditing turned on for your Azure SQL DB? If so, you might want to enter something like this: <server name>.database.secure.windows.net.

Regards,
George
Marked as answer by bmather on 3/4/2016 at 2:11 PM
Mar 4 at 9:11 PM
Perfect, that works - and I understand why!