Error Scripting Azure Table

Jul 27, 2015 at 9:53 PM
Edited Jul 27, 2015 at 10:04 PM
I'm trying to migrate an Azure database to a local SQL Server database. When I try to script a table (any table) using the wizard, I get the following error:

"Property RowCount is not available for Table '[dbo].[TableName]'. This property may not exist for this object, or may not be retrievable due to insufficient access rights."

I've tried many different combinations in the Advanced Settings screen but keep getting the error regardless of what I try. Any ideas on what might be causing this? Thanks!
Coordinator
Jul 27, 2015 at 11:43 PM
Hi,

Out of curiosity, what version of Azure SQL DB are you running:

1) Web or Business (Oldest)
2) Azure SQL DB (Old)
3) Azure SQL DB V12 (Latest version)

If you are running 1 or 2 above, you will probably need to upgrade to Azure SQL DB v12 in order to get SQLAzureMW to work.

If you are running Azure SQL DB v12, then we will need to take a closer look.

Sorry about the difficulty,
George
Jul 28, 2015 at 5:04 PM
Thanks for responding. It looks like we may be on an older version - we are on the Standard service tier. I will look into it a bit more. Thanks again!
Coordinator
Jul 30, 2015 at 4:15 PM
Hi,

How is it going? Just wanted to check and see if you were good to go.

Regards,
George
Jul 30, 2015 at 4:18 PM
Since we are on an older version, I decided to export the database and import it. This worked fine for me. Thanks again!
Coordinator
Jul 30, 2015 at 4:40 PM
I am glad you are up and running! Have a great day!