Compatibility With Sql Server 2014 ?

May 21 at 12:36 PM
Is version 4.0.1.8 compatible with Sql Server 2014? I'm getting the missing dependency error when I try to run it.
Coordinator
May 21 at 2:56 PM
Hi,

I actually have a SQLAzureMW v5 which is built on SQL Server 2014. I am still testing it, but if you want, I can email you an early zip of it so that you can play with it. It basically works with no problems from on-premise to Azure. The problem is from Azure to Azure or Azure to SQL. You can work around the buy by setting "Include if NOT Exists" to false in the advanced settings. Then I can go from Azure to Azure or Azure to SQL.

Anyway, contact me through codeplex and I will send you SQLAzureMW v5.

Regards,
George
May 21 at 10:03 PM
That would be great if you could send me the zip for v5.

I appreciate it. Thanks
May 25 at 2:11 PM
Would also love to get a copy of the SQL 2014 compatible version.

Thanks,

Brian
Jun 24 at 10:28 AM
In v5.0 when migrating from Azure Sql to local, all procedures/functions/views are not created.

Checking at the log of the app, there is a missing "GO" just before the Create View, etc.

Thanks,


Kostis
Coordinator
Jun 25 at 12:06 AM
Hi Kostis,

You are correct. I am working on the fix and hope to have it out soon.

Thanks for your feedback,
George
Coordinator
Jun 25 at 3:11 PM
Hi Kostis,

Ok, I believe that I have fixed it. Check out v5.0.1 and see what you think. If I missed something, please let me know.

Thanks very much,
George
Jun 25 at 9:57 PM
Hi George,

I just tried 5.0.1 and everything works as expected! No warnings, no errors... and everything is on my target database!

I really want to thank you for the fix!

Your work is great, you are (really) fast and your work help us more than you think! :)



Thanks again,


Kostis