Error: Index was outside the bounds of the array

Jan 27, 2012 at 10:10 AM

Hi,

i have installed and run the wizard and all works fine until i reach the phase where, after insert all data for connecting to a SQL Azure server the application try to retrieve the database list.

I get this error:

Index was outside the bounds of the array (Microsoft.SqlServer.Smo)

What can i do ??

Thanks

PS:
I Have SSMS 2008R2 and a local Sql 2008 R2 database

Coordinator
Jan 27, 2012 at 12:03 PM

The issue you described below is that SQL Azure requires applications using SMO to be running on SQL Server 2008 R2 SP1.  In July, SQL Azure upgraded the servers (for more info see: http://blogs.msdn.com/b/windowsazure/archive/2011/07/13/announcing-sql-azure-july-2011-service-release.aspx). These changes require that any program using SMO run on SQL Server 2008 R2 SP1. So, you need to download SP1 and you should be ok. You can download SQL Server 2008 R2 SP1 here: http://www.microsoft.com/download/en/details.aspx?id=26727

 

Regards,

George

 


Jan 27, 2012 at 1:21 PM

Thanks a lot.

after upgrading all works fine.

You have made a great product very simple and usefull !!!

Coordinator
Jan 27, 2012 at 9:48 PM

Thanks!!!

Feb 2, 2012 at 11:09 AM
Edited Feb 2, 2012 at 11:55 AM

Hello

This does not work for me. I've had my DB Admins update our test database to SP1, and I still get the error. I've tried only one table schema and it fails, any more ideas?

 

[edit] Reading the solutions more carefully, I think I need to update Management Studio as well... going to do that now and report back.

[edit2]Yep, I had to update my own installation of SQL Server (which in turn updates SSMS). All working now!