SQLAzureMW 3.7.7 crashes when uploading...

Nov 8, 2011 at 8:46 AM

Hi,

Just subscribed to SQL Azure and downloaded SQLAzureMW 3.7.7 then tried to migrate one of my databases.

All is working well (connections, scripts and .dat files creation, ...) until the message "Execute script against destination server?". When I press Yes, the process starts : the "CREATE TABLE....", "CREATE VIEW..." get Success lines but when it comes to upload data, the SQLAzureMW is crashing with message "SQLAzureMW has stopped working"....

Some of my tables have VARCHAR(MAX) fields and some of my tables have more than 200 colums... Has SQL Azure some limits in comparison with SQL Server 2008 R2 ?

Thanks for your future replies.

Phil

Nov 8, 2011 at 9:21 AM

Hi,

It seems that I found the problem : one my schema is named A4#COMMONDEMO and when I try to transfer data to this schema, the SQLAzureMW crashes, so the character # seems the problem. Can you confirm ?

The schema could be created on SQL Azure and the related tables could be created too : only the data upload crashes...

HTH,

Phil

Coordinator
Nov 9, 2011 at 12:56 AM


Hi Phil,

 

You are correct.  I have to trap special characters because they don’t play well with the file system and BCP.  I actually fixed this awhile back, but had my code torn apart to include new functionality for SQL Azure Federation so I have not posted any fixes for a couple of months.  If you don’t mind, download v3.7.8 and try again to verify that I did fix the issue.  If not, please let me know.

 

Thanks,

George

Nov 9, 2011 at 7:25 AM

Hi George,

Just downloaded v. 3.7.8 and I confirm you that  the # problem in the schema is resolved !

I found another error related with authorization :

09.11.2011 09:15:13 --> Error #: 15151 -- Cannot find the user 'a4phm', because it does not exist or you do not have permission.
CREATE SCHEMA failed due to previous errors.
IF NOT EXISTS (SELECT * FROM sys.schemas WHERE name = N'A4#COMMON')
EXEC sys.sp_executesql N'CREATE SCHEMA [A4#COMMON] AUTHORIZATION [a4phm]'C:\Users\phm>bcp pkltest.A4#COMMONDEMO.app in "C:\_Test\Scripts\zazdev\A4#COMMONDEMO.app_bcp.ass" -c -U USER@XXXXXXXX.database.windows.net -S tcp:XXXXXXX.database.windows.net -P XXXXX

the script includes the authorization (a4phm which is the user on my local database). Is this normal ?

Thanks for your future answer.

Great tool !

Phil

Coordinator
Nov 9, 2011 at 1:16 PM

Hi Phil,

 

Migration of users, such as a4pm, is not handled by SQLAzureMW.  You will have to migrate your users by hand first and then run the script.  This is something that I need to work on, but have not had the time to get it included or figured out how to get the actual password for the users.  What you can do if you want to is edit the script generated by SQLAzureMW before you run against target server and change a4pm to dbo and it will probably work.

 

Sorry I don’t have a batter answer for you,

George

 


Nov 9, 2011 at 1:26 PM

Hi George !

Thanks for your reply. This works now like a charm.

Cheers from Switzerland !

Phil