Migrating Data Only - Table columns must be in same order

Jun 3, 2011 at 11:35 PM

When migrating "data only", if the columns within a table are in a different order between the source database and destination database, errors are encountered when migrating the data. The errors are "unexpected EOF encountered in BCP data-file" or "Invalid field size for datatype".

I updated the column order in one database to match the other and the data was successfully migrated.

Is the column order requirement here to stay? Configuration option I haven't set?

Apologize in advance if this question has already been asked.

 

Coordinator
Jun 4, 2011 at 12:43 AM

Hi,

I use BCP to download and upload the data.  If you look at SQLAzureMW.exe.config file, you will see where I put the BCP parameters.  I use the -n switch.  I would suggest that you play with BCP outside of SQLAzureMW and see if you can unload from one table structure to upload to another (like you are trying to do).  You can try the -c switch or play with the queryout.  See http://msdn.microsoft.com/en-us/library/ms162802.aspx for more informaiton on BCP.  If you play with the queryout, you will have to do that outside of SQLAzureMW.

I hope this helps,
George